Once you have set off your journey in bringing engagement to your company, you may experience some grievances during the Survey Cycle. 

A common grouse from your employees may be that they did not receive a link to the survey. In this article, we share what to do if your Employee experiences this.

  1. Check your Survey Setup page and navigate to Manage Employees. A common mistake that may happen due to human error is a typo in the email address uploaded onto our system. Do verify that the information uploaded is accurate.
  2. The Survey Cycle hasn't begun. Navigate to your Communications Setup page and ensure that the date and time is correct. The Survey Cycle has to begin before any survey invites are delivered to your users' inboxes. 
  3. The email client that your Employee is using has a spam filter that has flagged our invite as Spam or Junk. Do ensure that this is not the case. In certain companies, awry email settings can channel even the most established of emails straight to the junk pile.

If all else fails, do contact one of our survey administrators, either through the Intercom application integrated in our platform, or shoot an email to [email protected]o.

There are alternative ways of accessing our surveys. You can use this article to understand how to send an invite to the survey to someone who did not receive the link. This method is the same as how users without email addresses access our surveys.

We hope that this article has been helpful!

Did this answer your question?